lugh.ch

as nerdy as needed.

TLS 1.0 end-of-life


The security protocol TLS 1.0 has been disabled on every service provided at lugh.ch.

What does this mean for me?

If your computer/mobile is not living behind a rock, then nothing changes and you can access Email, Webmail, Jabber and Nextcloud just like before.

How could I be affected?

Only if you use a very, very old client. The only solution is to upgrade your client and/or operating system. These are the minimum requirements:

OS resp. TLS implementations

  • Windows 7 or newer
  • OpenSSL 1.0.1 or newer

Browsers

  • Chrome: 22 or newer
  • Firefox: 24 or newer
  • Safari: 7 or newer
  • Edge: any version
  • IE: 11 or newer

Mobile phones

  • Android: 5.0 or newer
  • iOS: 5.0 or newer

Details: caniuse.com, wikipedia.org